Algorithm/Algorithm__hackerrank-Java

Introduction - Java Output Formatting

말하는감자 2022. 6. 21. 14:50

Q

Java's System.out.printf function can be used to print formatted output. The purpose of this exercise is to test your understanding of formatting output using printf.

To get you started, a portion of the solution is provided for you in the editor; you must format and print the input to complete the solution.

Input Format

Every line of input will contain a String followed by an integer.
Each String will have a maximum of  alphabetic characters, and each integer will be in the inclusive range from  to .

Output Format

In each line of output there should be two columns:
The first column contains the String and is left justified using exactly  characters.
The second column contains the integer, expressed in exactly  digits; if the original input has less than three digits, you must pad your output's leading digits with zeroes.

Sample Input

java 100
cpp 65
python 50

Sample Output

================================
java           100 
cpp            065 
python         050 
================================

Explanation

Each String is left-justified with trailing whitespace through the first  characters. The leading digit of the integer is the  character, and each integer that was less than  digits now has leading zeroes.

 

A

import java.util.Scanner;

public class Solution {

    public static void main(String[] args) {
            Scanner sc=new Scanner(System.in);
            System.out.println("================================");
            for(int i=0;i<3;i++){
                String s1=sc.next();
                int x=sc.nextInt();
                //Complete this line
                String str1 = String.format("%-15s", s1);
                String str2 = String.format("%03d", x);
                System.out.println(str1 + str2);
            }
            System.out.println("================================");

    }
}

 

'Algorithm > Algorithm__hackerrank-Java' 카테고리의 다른 글

Currency Formatter  (0) 2022.06.21
Date And Time  (0) 2022.06.21
End-of-file  (0) 2022.06.21
Introduction - Java Datatypes  (0) 2022.06.21
Introduction - Java Loops II  (0) 2022.06.21